{"answers":{"affected":"5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-22135 in the wild and no public exploit code.","fix":"Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.15 or 7.11.2.","what":"CVE-2021-22135 is a medium-severity vulnerability in Elastic Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22135 and fix it if it is affected.\n\nWhat it is: CVE-2021-22135 is a medium-severity vulnerability in Elastic Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22135 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.15\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.15\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.11.2\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.11.2\n- elasticsearch (Bitnami): affected all versions; fixed in 6.8.15, 7.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22135/ (Markdown: https://insights.sbomify.com/CVE-2021-22135/index.md)","id":"CVE-2021-22135","markdown":"https://insights.sbomify.com/CVE-2021-22135/index.md","name":"CVE-2021-22135","record":{"aliases":["BIT-elasticsearch-2021-22135","GHSA-62ww-4p3p-7fhj","UBUNTU-CVE-2021-22135"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Elasticsearch search engine","requires_auth":"none","summary":"Attackers can bypass document and field level security restrictions to disclose the existence of protected documents and fields via the suggester and profile APIs.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"elasticsearch","vendor":"elastic"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Elasticsearch versions before 7.11.2 and 6.8.15 contain a document disclosure flaw was found in the Elasticsearch suggester and profile API when Document and Field Level Security are enabled. The suggester and profile API are normally disabled for an index when document level security is enabled on the index. Certain queries are able to enable the profiler and suggester which could lead to disclosing the existence of documents and fields the attacker should not be able to view.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"API information disclosure flaw in Elasticsearch","id":"CVE-2021-22135","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"elastic:elasticsearch","products":["elastic:elasticsearch"],"type":"information_disclosure","year":"2021"},"n_packages":5,"n_references":2,"next":{"headline":"Security feature bypass in Kibana","id":"CVE-2021-22136"},"packages":[{"ecosystem":"Bitnami","fixed":["6.8.15","7.11.2"],"introduced":["0","7.11.0"],"last_affected":[],"package":"elasticsearch","purl":"pkg:bitnami/elasticsearch","source":"BIT-elasticsearch-2021-22135"},{"ecosystem":"Maven","fixed":["6.8.15"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-62ww-4p3p-7fhj"},{"ecosystem":"Maven","fixed":["6.8.15"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-62ww-4p3p-7fhj"},{"ecosystem":"Maven","fixed":["7.11.2"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-62ww-4p3p-7fhj"},{"ecosystem":"Maven","fixed":["7.11.2"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-62ww-4p3p-7fhj"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2021-22134"},"products":["Elasticsearch"],"published":"2021-05-13","related":[{"cvss_score":9.8,"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427","kev_date_added":"2022-03-25","published":"2015-02-17"},{"cvss_score":8.1,"headline":"Elasticsearch Remote Code Execution","id":"CVE-2014-3120","kev_date_added":"2022-03-25","published":"2014-07-28"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2015-5377","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution","id":"CVE-2026-72649","kev_date_added":null,"published":"2026-09-01"},{"cvss_score":8.8,"headline":"Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process","id":"CVE-2026-72642","kev_date_added":null,"published":"2026-08-13"},{"cvss_score":8.8,"headline":"Privilege Escalation Flaw in Elasticsearch","id":"CVE-2020-7014","kev_date_added":null,"published":"2020-06-03"},{"cvss_score":8.8,"headline":"Improper Privilege Management in Elasticsearch","id":"CVE-2020-7009","kev_date_added":null,"published":"2020-03-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Elastic"]},"summary":"Attackers can bypass document and field level security restrictions to disclose the existence of protected documents and fields via the suggester and profile APIs.","url":"https://insights.sbomify.com/CVE-2021-22135/"}