CVE-2021-22137 Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch
Attackers can bypass Document or Field Level Security in cross-cluster searches to reveal the existence of restricted documents, leaking sensitive index metadata.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22137?
CVE-2021-22137 is a medium-severity vulnerability in Elastic Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.
Which versions are affected by CVE-2021-22137?
5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.elasticsearch:elasticsearch Maven | All versions | 6.8.15 |
org.elasticsearch:elasticsearch Maven | All versions | 6.8.15 |
org.elasticsearch:elasticsearch Maven | From 7.11.0 | 7.11.2 |
org.elasticsearch:elasticsearch Maven | From 7.11.0 | 7.11.2 |
elasticsearch Bitnami | All versions | 6.8.15, 7.11.2 |
Products include Elastic Elasticsearch.
How do I fix CVE-2021-22137?
Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.15 or 7.11.2.
Is CVE-2021-22137 being exploited?
There is no known exploitation of CVE-2021-22137 in the wild and no public exploit code.
Other vulnerabilities in Elastic Elasticsearch
- CVE-2015-1427 Elasticsearch Groovy Scripting Engine Remote Code Execution
- CVE-2014-3120 Elasticsearch Remote Code Execution
- CVE-2015-5377 Code injection in n/a
- CVE-2026-72649 Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution
- CVE-2026-72642 Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process
Sources
Also known as BIT-elasticsearch-2021-22137, GHSA-hr65-qq6p-87r4, UBUNTU-CVE-2021-22137.