# CVE-2021-22137: Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch

> Attackers can bypass Document or Field Level Security in cross-cluster searches to reveal the existence of restricted documents, leaking sensitive index metadata.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2021-22137, GHSA-hr65-qq6p-87r4, UBUNTU-CVE-2021-22137

## What is CVE-2021-22137?

CVE-2021-22137 is a medium-severity vulnerability in Elastic Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Weakness: CWE-281 (Improper Preservation of Permissions), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-22137?

5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.15 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.15 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.11.0 | 7.11.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.11.0 | 7.11.2 |
| `elasticsearch` | Bitnami | All versions | 6.8.15, 7.11.2 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2021-22137?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.15 or 7.11.2.

## Is CVE-2021-22137 being exploited?

There is no known exploitation of CVE-2021-22137 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22137 and fix it if it is affected.

What it is: CVE-2021-22137 is a medium-severity vulnerability in Elastic Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22137 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.15
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.15
- org.elasticsearch:elasticsearch (Maven): affected from 7.11.0; fixed in 7.11.2
- org.elasticsearch:elasticsearch (Maven): affected from 7.11.0; fixed in 7.11.2
- elasticsearch (Bitnami): affected all versions; fixed in 6.8.15, 7.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22137/ (Markdown: https://insights.sbomify.com/CVE-2021-22137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22137
- OSV: https://osv.dev/vulnerability/CVE-2021-22137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22137/
Summaries are generated and may contain mistakes; the official description above is the record.
