CVE-2021-22138 Security feature bypass in Elasticsearch

Low 3.7 Published Updated

Attackers can intercept Logstash monitoring data via man-in-the-middle attacks due to improper TLS certificate validation when a trusted CA is specified.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22138?

CVE-2021-22138 is a low-severity vulnerability in Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Logstash versions after 6.4.0 and before 6.8.15 and 7.12.0 a TLS certificate validation flaw was found in the monitoring feature. When specifying a trusted server CA certificate Logstash would not properly verify the certificate returned by the monitoring server. This could result in a man in the middle style attack against the Logstash monitoring data.

Weakness: CWE-295

Which versions are affected by CVE-2021-22138?

1 open source package ship an affected version, including logstash. It affects 1 product.

PackageAffectedFixed in
logstash BitnamiFrom 6.4.06.8.15, 7.12.0

Products include Elastic Logstash.

How do I fix CVE-2021-22138?

Upgrade logstash to a fixed version for your release line: 6.8.15 or 7.12.0.

Is CVE-2021-22138 being exploited?

There is no known exploitation of CVE-2021-22138 in the wild and no public exploit code.

Sources

Also known as BIT-logstash-2021-22138, GHSA-56cm-rmmq-hqpv.

Is CVE-2021-22138 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free