{"answers":{"affected":"1 open source package ship an affected version, including logstash. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-22138 in the wild and no public exploit code.","fix":"Upgrade logstash to a fixed version for your release line: 6.8.15 or 7.12.0.","what":"CVE-2021-22138 is a low-severity vulnerability in Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22138 and fix it if it is affected.\n\nWhat it is: CVE-2021-22138 is a low-severity vulnerability in Elasticsearch, published on 13 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22138 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- logstash (Bitnami): affected from 6.4.0; fixed in 6.8.15, 7.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22138/ (Markdown: https://insights.sbomify.com/CVE-2021-22138/index.md)","id":"CVE-2021-22138","markdown":"https://insights.sbomify.com/CVE-2021-22138/index.md","name":"CVE-2021-22138","record":{"aliases":["BIT-logstash-2021-22138","GHSA-56cm-rmmq-hqpv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Logstash monitoring","requires_auth":"none","summary":"Attackers can intercept Logstash monitoring data via man-in-the-middle attacks due to improper TLS certificate validation when a trusted CA is specified.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"logstash","vendor":"elastic"}],"cvss":{"score":3.7,"severity":"low","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"In Logstash versions after 6.4.0 and before 6.8.15 and 7.12.0 a TLS certificate validation flaw was found in the monitoring feature. When specifying a trusted server CA certificate Logstash would not properly verify the certificate returned by the monitoring server. This could result in a man in the middle style attack against the Logstash monitoring data.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in Elasticsearch","id":"CVE-2021-22138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Denial of service in Kibana","id":"CVE-2021-22139"},"packages":[{"ecosystem":"Bitnami","fixed":["6.8.15","7.12.0"],"introduced":["6.4.0","7.0.0"],"last_affected":[],"package":"logstash","purl":"pkg:bitnami/logstash","source":"BIT-logstash-2021-22138"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch","id":"CVE-2021-22137"},"products":["Elasticsearch"],"published":"2021-05-13","related":[{"cvss_score":9.8,"headline":"Information disclosure in Logstash","id":"CVE-2019-7612","kev_date_added":null,"published":"2019-03-25"},{"cvss_score":8.4,"headline":"Logstash Insertion of Sensitive Information into Log File","id":"CVE-2023-46672","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.1,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write","id":"CVE-2026-33466","kev_date_added":null,"published":"2026-04-08"},{"cvss_score":7.5,"headline":"Denial of service in Logstash","id":"CVE-2019-7620","kev_date_added":null,"published":"2019-10-30"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2015-5378","kev_date_added":null,"published":"2017-06-27"},{"cvss_score":7.5,"headline":"Logstash Logs Sensitive Information","id":"CVE-2016-1000221","kev_date_added":null,"published":"2017-06-16"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2016-1000222","kev_date_added":null,"published":"2017-06-16"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Elastic"]},"summary":"Attackers can intercept Logstash monitoring data via man-in-the-middle attacks due to improper TLS certificate validation when a trusted CA is specified.","url":"https://insights.sbomify.com/CVE-2021-22138/"}