CVE-2021-22144 Denial of Service in Elasticsearch
An attacker can crash Elasticsearch nodes by submitting malicious Grok queries, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22144?
CVE-2021-22144 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 26 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser. A user with the ability to submit arbitrary queries to Elasticsearch could create a malicious Grok query that will crash the Elasticsearch node.
Weakness: CWE-674
Which versions are affected by CVE-2021-22144?
5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.elasticsearch:elasticsearch Maven | All versions | 6.8.17 |
org.elasticsearch:elasticsearch Maven | All versions | 6.8.17 |
org.elasticsearch:elasticsearch Maven | From 7.0.0-alpha1 | 7.13.3 |
org.elasticsearch:elasticsearch Maven | From 7.0.0-alpha1 | 7.13.3 |
elasticsearch Bitnami | All versions | 6.8.17, 7.13.3 |
Products include Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.
How do I fix CVE-2021-22144?
Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.17 or 7.13.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-22144 being exploited?
There is no known exploitation of CVE-2021-22144 in the wild and no public exploit code.
Other vulnerabilities in Elastic Elasticsearch
- CVE-2015-1427 Elasticsearch Groovy Scripting Engine Remote Code Execution
- CVE-2014-3120 Elasticsearch Remote Code Execution
- CVE-2015-5377 Code injection in n/a
- CVE-2026-72649 Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution
- CVE-2026-72642 Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process
Sources
Also known as BIT-elasticsearch-2021-22144, GHSA-3393-hvrj-w7v3, UBUNTU-CVE-2021-22144.