# CVE-2021-22144: Denial of Service in Elasticsearch

> An attacker can crash Elasticsearch nodes by submitting malicious Grok queries, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2021-22144, GHSA-3393-hvrj-w7v3, UBUNTU-CVE-2021-22144

## What is CVE-2021-22144?

CVE-2021-22144 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 26 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser. A user with the ability to submit arbitrary queries to Elasticsearch could create a malicious Grok query that will crash the Elasticsearch node.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2021-22144?

5 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.17 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 6.8.17 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0-alpha1 | 7.13.3 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.0.0-alpha1 | 7.13.3 |
| `elasticsearch` | Bitnami | All versions | 6.8.17, 7.13.3 |

Products: Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2021-22144?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.17 or 7.13.3.

## Is CVE-2021-22144 being exploited?

There is no known exploitation of CVE-2021-22144 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22144 and fix it if it is affected.

What it is: CVE-2021-22144 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 26 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22144 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.17
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.17
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0-alpha1; fixed in 7.13.3
- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0-alpha1; fixed in 7.13.3
- elasticsearch (Bitnami): affected all versions; fixed in 6.8.17, 7.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22144/ (Markdown: https://insights.sbomify.com/CVE-2021-22144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22144
- OSV: https://osv.dev/vulnerability/CVE-2021-22144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22144/
Summaries are generated and may contain mistakes; the official description above is the record.
