# CVE-2021-22145: Generation of Error Message Containing Sensitive Information in Elasticsearch

> Attackers can submit malformed queries to Elasticsearch to retrieve sensitive data from memory buffers, including documents and authentication details.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2021
- **Updated:** 8 Jul 2025
- **Also known as:** BIT-elasticsearch-2021-22145, GHSA-q394-h7f5-7f44, UBUNTU-CVE-2021-22145

## What is CVE-2021-22145?

CVE-2021-22145 is a medium-severity vulnerability in Elastic Elasticsearch, published on 21 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A memory disclosure vulnerability was identified in Elasticsearch 7.10.0 to 7.13.3 error reporting. A user with the ability to submit arbitrary queries to Elasticsearch could submit a malformed query that would result in an error message returned containing previously used portions of a data buffer. This buffer could contain sensitive information such as Elasticsearch documents or authentication details.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-22145?

3 open source packages ship an affected version, including org.elasticsearch.client:elasticsearch-rest-client and elasticsearch. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch.client:elasticsearch-rest-client` | Maven | From 7.10.0 | 7.13.4 |
| `org.elasticsearch.client:elasticsearch-rest-client` | Maven | From 7.10.0 | 7.13.4 |
| `elasticsearch` | Bitnami | From 7.10.0 | 7.13.4 |

Products: Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2021-22145?

Upgrade org.elasticsearch.client:elasticsearch-rest-client to 7.13.4 or later.

## Is CVE-2021-22145 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-22145 exists.

Public exploit code:

- Elasticsearch Memory Disclosure (metasploit)
- ElasticSearch 7.13.3 - Memory disclosure (exploitdb)
- https://github.com/niceeeeeeee/CVE-2021-22145-poc (github_poc): https://github.com/niceeeeeeee/CVE-2021-22145-poc
- Elasticsearch 7.10.0-7.13.3 - Information Disclosure (nuclei): http/cves/2021/CVE-2021-22145.yaml

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22145 and fix it if it is affected.

What it is: CVE-2021-22145 is a medium-severity vulnerability in Elastic Elasticsearch, published on 21 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-22145 exists.

Affected packages and fixed versions:
- org.elasticsearch.client:elasticsearch-rest-client (Maven): affected from 7.10.0; fixed in 7.13.4
- org.elasticsearch.client:elasticsearch-rest-client (Maven): affected from 7.10.0; fixed in 7.13.4
- elasticsearch (Bitnami): affected from 7.10.0; fixed in 7.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22145/ (Markdown: https://insights.sbomify.com/CVE-2021-22145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22145
- OSV: https://osv.dev/vulnerability/CVE-2021-22145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22145/
Summaries are generated and may contain mistakes; the official description above is the record.
