# CVE-2021-22146: Information disclosure in n/a

> Attackers can gain insight into cluster details via the default enabled anonymous user in Elastic Cloud Enterprise deployments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2021-22146, GHSA-wxcx-pqjc-2pp9

## What is CVE-2021-22146?

CVE-2021-22146 is a high-severity vulnerability in Elastic Elasticsearch, published on 21 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled by default in deployed clusters. While in the default setting the anonymous user has no permissions and is unable to successfully query any Elasticsearch APIs, an attacker could leverage the anonymous user to gain insight into certain details of a deployed cluster.

## Which versions are affected by CVE-2021-22146?

1 open source package ship an affected version, including elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elasticsearch` | Bitnami | From 7.13.3 | 7.13.4 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2021-22146?

Upgrade elasticsearch to 7.13.4 or later.

## Is CVE-2021-22146 being exploited?

There is no known exploitation of CVE-2021-22146 in the wild and no public exploit code.

Public exploit code:

- https://github.com/magichk/cve-2021-22146 (github_poc): https://github.com/magichk/cve-2021-22146
- Elasticsearch ECE 7.13.3 - Anonymous Database Dump (exploitdb)

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22146 and fix it if it is affected.

What it is: CVE-2021-22146 is a high-severity vulnerability in Elastic Elasticsearch, published on 21 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22146 in the wild and no public exploit code.

Affected packages and fixed versions:
- elasticsearch (Bitnami): affected from 7.13.3; fixed in 7.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22146/ (Markdown: https://insights.sbomify.com/CVE-2021-22146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22146
- OSV: https://osv.dev/vulnerability/CVE-2021-22146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22146/
Summaries are generated and may contain mistakes; the official description above is the record.
