# CVE-2021-22160: Authentication with JWT allows use of “none”-algorithm

> Attackers can bypass authentication and gain admin access by using JWTs with the 'none' algorithm in Apache Pulsar instances configured for token-based auth.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3cv4-xxv7-934q

## What is CVE-2021-22160?

CVE-2021-22160 is a critical authentication bypass vulnerability in Apache Pulsar, published on 26 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If Apache Pulsar is configured to authenticate clients using tokens based on JSON Web Tokens (JWT), the signature of the token is not validated if the algorithm of the presented token is set to "none". This allows an attacker to connect to Pulsar instances as any user (incl. admins).

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2021-22160?

2 open source packages ship an affected version, including org.apache.pulsar:pulsar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.7.2 |
| `org.apache.pulsar:pulsar` | Maven | All versions | 2.7.2 |

Products: Apache Pulsar.

## How do I fix CVE-2021-22160?

Upgrade org.apache.pulsar:pulsar to 2.7.2 or later.

## Is CVE-2021-22160 being exploited?

There is no known exploitation of CVE-2021-22160 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)
- [CVE-2022-34321](https://insights.sbomify.com/CVE-2022-34321/): Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22160 and fix it if it is affected.

What it is: CVE-2021-22160 is a critical authentication bypass vulnerability in Apache Pulsar, published on 26 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22160 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.2
- org.apache.pulsar:pulsar (Maven): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22160/ (Markdown: https://insights.sbomify.com/CVE-2021-22160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22160
- OSV: https://osv.dev/vulnerability/CVE-2021-22160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22160/
Summaries are generated and may contain mistakes; the official description above is the record.
