CVE-2021-22170 Weak cryptography in GitLab
Nonce reuse flaws allow attackers with database access to decrypt sensitive encrypted content in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22170?
CVE-2021-22170 is a medium-severity vulnerability in Gitlab Gitlab, published on 6 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Assuming a database breach, nonce reuse issues in GitLab 11.6+ allows an attacker to decrypt some of the database's encrypted content
Weakness: CWE-327
Which versions are affected by CVE-2021-22170?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.6.0 | 13.5.6, 13.6.4, 13.7.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22170?
Upgrade gitlab to a fixed version for your release line: 13.5.6, 13.6.4 or 13.7.2.
Is CVE-2021-22170 being exploited?
There is no known exploitation of CVE-2021-22170 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22170, GHSA-65v8-8343-jcqr, UBUNTU-CVE-2021-22170.