CVE-2021-22171 Auth bypass in GitLab
Attackers can steal victim API tokens via malicious links due to insufficient authentication validation in GitLab Pages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-22171?
CVE-2021-22171 is a high-severity authentication bypass vulnerability in Gitlab Gitlab, published on 15 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Insufficient validation of authentication parameters in GitLab Pages for GitLab 11.5+ allows an attacker to steal a victim's API token if they click on a maliciously crafted link
Weakness: CWE-287
Which versions are affected by CVE-2021-22171?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.5.0 | 13.5.6, 13.6.4, 13.7.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22171?
Upgrade gitlab to a fixed version for your release line: 13.5.6, 13.6.4 or 13.7.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-22171 being exploited?
There is no known exploitation of CVE-2021-22171 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22171, GHSA-2j76-jpwv-99mp.