CVE-2021-22177 Denial of service in GitLab
An attacker can cause a denial of service by spiking server resource utilization via gitlab-shell commands in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22177?
CVE-2021-22177 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Potential DoS was identified in gitlab-shell in GitLab CE/EE version 12.6.0 or above, which allows an attacker to spike the server resource utilization via gitlab-shell command.
Weakness: CWE-400
Which versions are affected by CVE-2021-22177?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.6.0 | 13.6.7, 13.7.7, 13.8.4 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22177?
Upgrade gitlab to a fixed version for your release line: 13.6.7, 13.7.7 or 13.8.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-22177 being exploited?
There is no known exploitation of CVE-2021-22177 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22177, GHSA-vx5g-jgx3-6mx9, UBUNTU-CVE-2021-22177.