CVE-2021-22185 Cross-site scripting in GitLab

Medium 5.4 Published Updated

An attacker can execute arbitrary scripts in victim browsers via stored XSS in GitLab wikis, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22185?

CVE-2021-22185 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 24 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Insufficient input sanitization in wikis in GitLab version 13.8 and up allows an attacker to exploit a stored cross-site scripting vulnerability via a specially-crafted commit to a wiki

Weakness: CWE-79

Which versions are affected by CVE-2021-22185?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.8.013.8.5, 13.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22185?

Upgrade gitlab to a fixed version for your release line: 13.8.5 or 13.9.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-22185 being exploited?

There is no known exploitation of CVE-2021-22185 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22185, GHSA-wf25-2f67-3rmc.

Is CVE-2021-22185 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free