CVE-2021-22186 Missing authorization in GitLab

Medium 4.9 Published Updated

A group maintainer can modify restricted CI/CD variables, allowing unauthorized configuration changes and potential privilege escalation in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22186?

CVE-2021-22186 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 24 Mar 2021. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An authorization issue in GitLab CE/EE version 9.4 and up allowed a group maintainer to modify group CI/CD variables which should be restricted to group owners

Weakness: CWE-863

Which versions are affected by CVE-2021-22186?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.4.013.7.8, 13.8.5, 13.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22186?

Upgrade gitlab to a fixed version for your release line: 13.7.8, 13.8.5 or 13.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-22186 being exploited?

There is no known exploitation of CVE-2021-22186 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22186, GHSA-g5rc-vv3j-cq5q, UBUNTU-CVE-2021-22186.

Is CVE-2021-22186 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free