CVE-2021-22187 Denial of service in GitLab

Medium 4.3 Published Updated

Attackers can cause resource exhaustion by keeping jobs running after project deletion, impacting GitLab availability.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22187?

CVE-2021-22187 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 2 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions of Gitlab EE/CE before 13.6.7. A potential resource exhaustion issue that allowed running or pending jobs to continue even after project was deleted.

Weakness: CWE-400

Which versions are affected by CVE-2021-22187?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions13.6.7, 13.7.7, 13.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2021-22187?

Upgrade gitlab to a fixed version for your release line: 13.6.7, 13.7.7 or 13.8.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-22187 being exploited?

There is no known exploitation of CVE-2021-22187 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22187, GHSA-jx85-pcwq-c9wc, UBUNTU-CVE-2021-22187.

Is CVE-2021-22187 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free