CVE-2021-22203 Path traversal in GitLab
Attackers can read arbitrary files on the server via a specially crafted Wiki page in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22203?
CVE-2021-22203 is a high-severity path traversal vulnerability in Gitlab Gitlab, published on 2 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.7.9 before 13.8.7, all versions starting from 13.9 before 13.9.5, and all versions starting from 13.10 before 13.10.1. A specially crafted Wiki page allowed attackers to read arbitrary files on the server.
Which versions are affected by CVE-2021-22203?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.7.9 | 13.8.7, 13.9.5, 13.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22203?
Upgrade gitlab to a fixed version for your release line: 13.8.7, 13.9.5 or 13.10.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-22203 being exploited?
There is no known exploitation of CVE-2021-22203 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22203, GHSA-gqf8-2wm9-vgqf, UBUNTU-CVE-2021-22203.