CVE-2021-22217 Denial of service in GitLab

Medium 6.5 Published Updated

An attacker can cause uncontrolled resource consumption and denial of service in GitLab by submitting specially crafted issues or merge requests.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22217?

CVE-2021-22217 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 8 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service vulnerability in all versions of GitLab CE/EE before 13.12.2, 13.11.5 or 13.10.5 allows an attacker to cause uncontrolled resource consumption with a specially crafted issue or merge request

Which versions are affected by CVE-2021-22217?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions13.10.5, 13.11.5, 13.12.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22217?

Upgrade gitlab to a fixed version for your release line: 13.10.5, 13.11.5 or 13.12.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-22217 being exploited?

There is no known exploitation of CVE-2021-22217 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22217, GHSA-r8qj-g779-h5pv, UBUNTU-CVE-2021-22217.

Is CVE-2021-22217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free