CVE-2021-22221 Auth bypass in GitLab

Medium 6.5 Published Updated

Insufficient expired password validation allows users to maintain limited access after their password expires, bypassing authentication controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22221?

CVE-2021-22221 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 8 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 12.9.0 before 13.10.5, all versions starting from 13.11.0 before 13.11.5, all versions starting from 13.12.0 before 13.12.2. Insufficient expired password validation in various operations allow user to maintain limited access after their password expired

Weakness: CWE-613

Which versions are affected by CVE-2021-22221?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.013.10.5, 13.11.5, 13.12.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22221?

Upgrade gitlab to a fixed version for your release line: 13.10.5, 13.11.5 or 13.12.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2021-22221 being exploited?

There is no known exploitation of CVE-2021-22221 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22221, GHSA-2p89-vr82-6vw5, UBUNTU-CVE-2021-22221.

Is CVE-2021-22221 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free