CVE-2021-22224 Cross-site request forgery in GitLab
An attacker can perform unauthorized actions on behalf of a victim via the GraphQL API in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-22224?
CVE-2021-22224 is a high-severity vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A cross-site request forgery vulnerability in the GraphQL API in GitLab since version 13.12 and before versions 13.12.6 and 14.0.2 allowed an attacker to call mutations as the victim
Weakness: CWE-352
Which versions are affected by CVE-2021-22224?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.12.0 | 13.12.6, 14.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22224?
Upgrade gitlab to a fixed version for your release line: 13.12.6 or 14.0.2.
Is CVE-2021-22224 being exploited?
There is no known exploitation of CVE-2021-22224 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22224, GHSA-3f26-542m-36hv, UBUNTU-CVE-2021-22224.