CVE-2021-22225 Cross-site scripting in GitLab

Medium 4.7 Published Updated

An attacker can execute arbitrary scripts in victim browsers via stored cross-site scripting in GitLab markdown, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22225?

CVE-2021-22225 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Insufficient input sanitization in markdown in GitLab version 13.11 and up allows an attacker to exploit a stored cross-site scripting vulnerability via a specially-crafted markdown

Weakness: CWE-79

Which versions are affected by CVE-2021-22225?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.11.313.11.6, 13.12.6, 14.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22225?

Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-22225 being exploited?

There is no known exploitation of CVE-2021-22225 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22225, GHSA-27v4-8jv4-3cp6, UBUNTU-CVE-2021-22225.

Is CVE-2021-22225 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free