CVE-2021-22227 Cross-site scripting in GitLab

Medium 6.1 Published Updated

An attacker can execute arbitrary scripts in a victim's browser via a malicious link, potentially leading to account takeover or unauthorized actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22227?

CVE-2021-22227 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A reflected cross-site script vulnerability in GitLab before versions 13.11.6, 13.12.6 and 14.0.2 allowed an attacker to send a malicious link to a victim and trigger actions on their behalf if they clicked it

Weakness: CWE-79

Which versions are affected by CVE-2021-22227?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.013.11.6, 13.12.6, 14.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22227?

Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-22227 being exploited?

There is no known exploitation of CVE-2021-22227 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22227, GHSA-67r7-3vf2-fjcp, UBUNTU-CVE-2021-22227.

Is CVE-2021-22227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free