# CVE-2021-22227: Cross-site scripting in GitLab

> An attacker can execute arbitrary scripts in a victim's browser via a malicious link, potentially leading to account takeover or unauthorized actions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-gitlab-2021-22227, GHSA-67r7-3vf2-fjcp, UBUNTU-CVE-2021-22227

## What is CVE-2021-22227?

CVE-2021-22227 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site script vulnerability in GitLab before versions 13.11.6, 13.12.6 and 14.0.2 allowed an attacker to send a malicious link to a victim and trigger actions on their behalf if they clicked it

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-22227?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 12.9.0 | 13.11.6, 13.12.6, 14.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2021-22227?

Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.

## Is CVE-2021-22227 being exploited?

There is no known exploitation of CVE-2021-22227 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22227 and fix it if it is affected.

What it is: CVE-2021-22227 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22227 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 12.9.0; fixed in 13.11.6, 13.12.6, 14.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22227/ (Markdown: https://insights.sbomify.com/CVE-2021-22227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22227
- OSV: https://osv.dev/vulnerability/CVE-2021-22227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22227/
Summaries are generated and may contain mistakes; the official description above is the record.
