CVE-2021-22230 Cross-site scripting in GitLab
Attackers can inject malicious code via merge requests, potentially leading to code execution or account takeover in GitLab.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22230?
CVE-2021-22230 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jul 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper code rendering while rendering merge requests could be exploited to submit malicious code. This vulnerability affects GitLab CE/EE 9.3 and later through 13.11.6, 13.12.6, and 14.0.2.
Which versions are affected by CVE-2021-22230?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 9.3.0 | 13.11.6, 13.12.6, 14.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22230?
Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-22230 being exploited?
There is no known exploitation of CVE-2021-22230 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22230, GHSA-r6rg-m239-gjp4, UBUNTU-CVE-2021-22230.