CVE-2021-22232 Cross-site scripting in GitLab
Attackers can inject HTML via the full name field in GitLab CE, potentially leading to script execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-22232?
CVE-2021-22232 is a low-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 6 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
HTML injection was possible via the full name field before versions 13.11.6, 13.12.6, and 14.0.2 in GitLab CE
Weakness: CWE-74
Which versions are affected by CVE-2021-22232?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 9.5.0 | 13.11.6, 13.12.6, 14.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22232?
Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-22232 being exploited?
There is no known exploitation of CVE-2021-22232 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22232, GHSA-q5w6-p37j-cwr4, UBUNTU-CVE-2021-22232.