CVE-2021-22246 Denial of service in GitLab
Attackers can abuse the GitLab Webhook feature to perform denial of service attacks, requiring administrators to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22246?
CVE-2021-22246 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 20 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was discovered in GitLab versions before 14.0.2, 13.12.6, 13.11.6. GitLab Webhook feature could be abused to perform denial of service attacks.
Weakness: CWE-770
Which versions are affected by CVE-2021-22246?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 2.0.0 | 13.11.6, 13.12.6, 14.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22246?
Upgrade gitlab to a fixed version for your release line: 13.11.6, 13.12.6 or 14.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-22246 being exploited?
There is no known exploitation of CVE-2021-22246 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22246, GHSA-q6jf-84qm-cj59, UBUNTU-CVE-2021-22246.