CVE-2021-22254 Auth bypass in GitLab

Low 3.1 Published Updated

Attackers can impersonate users under specific conditions in GitLab, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22254?

CVE-2021-22254 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 20 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Under very specific conditions a user could be impersonated using Gitlab shell. This vulnerability affects GitLab CE/EE 13.1 and later through 14.1.2, 14.0.7 and 13.12.9.

Weakness: CWE-116

Which versions are affected by CVE-2021-22254?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.1.013.12.9, 14.0.7, 14.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22254?

Upgrade gitlab to a fixed version for your release line: 13.12.9, 14.0.7 or 14.1.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2021-22254 being exploited?

There is no known exploitation of CVE-2021-22254 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22254, GHSA-g4px-p74v-q4c7, UBUNTU-CVE-2021-22254.

Is CVE-2021-22254 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free