CVE-2021-22260 Cross-site scripting in GitLab

High 7.7 Published Updated

Stored XSS in GitLab's DataDog integration allows attackers to execute arbitrary JavaScript on victims, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22260?

CVE-2021-22260 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 4 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored Cross-Site Scripting vulnerability in the DataDog integration in all versions of GitLab CE/EE starting from 13.7 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to execute arbitrary JavaScript code on the victim's behalf

Weakness: CWE-79

Which versions are affected by CVE-2021-22260?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.7.014.0.9, 14.1.4, 14.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22260?

Upgrade gitlab to a fixed version for your release line: 14.0.9, 14.1.4 or 14.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-22260 being exploited?

There is no known exploitation of CVE-2021-22260 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22260, GHSA-87x4-89mh-jmjg, UBUNTU-CVE-2021-22260.

Is CVE-2021-22260 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free