CVE-2021-22261 Cross-site scripting in GitLab

High 7.3 Published Updated

An attacker can execute arbitrary JavaScript on victims via malicious Jira API responses in GitLab's Jira integration.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22261?

CVE-2021-22261 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Oct 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A stored Cross-Site Scripting vulnerability in the Jira integration in all GitLab versions starting from 13.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to execute arbitrary JavaScript code on the victim's behalf via malicious Jira API responses

Weakness: CWE-79

Which versions are affected by CVE-2021-22261?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.9.014.0.9, 14.1.4, 14.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-22261?

Upgrade gitlab to a fixed version for your release line: 14.0.9, 14.1.4 or 14.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-22261 being exploited?

There is no known exploitation of CVE-2021-22261 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-22261, GHSA-2vqg-gr4m-v458, UBUNTU-CVE-2021-22261.

Is CVE-2021-22261 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free