CVE-2021-22263 Privilege escalation in GitLab
External users with Maintainer roles can escalate privileges to Internal status, gaining unauthorized access to internal projects.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22263?
CVE-2021-22263 is a medium-severity vulnerability in Gitlab Gitlab, published on 11 Oct 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 13.0 before 14.0.9, all versions starting from 14.1 before 14.1.4, all versions starting from 14.2 before 14.2.2. A user account with 'external' status which is granted 'Maintainer' role on any project on the GitLab instance where 'project tokens' are allowed may elevate its privilege to 'Internal' and access Internal projects.
Weakness: CWE-269
Which versions are affected by CVE-2021-22263?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.0.0 | 14.0.9, 14.1.4, 14.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-22263?
Upgrade gitlab to a fixed version for your release line: 14.0.9, 14.1.4 or 14.2.2.
Is CVE-2021-22263 being exploited?
There is no known exploitation of CVE-2021-22263 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-22263, GHSA-prvv-j9vx-7x9q, UBUNTU-CVE-2021-22263.