{"answers":{"affected":"3 open source packages ship an affected version, including github.com/google/exposure-notifications-verification-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-22565 in the wild and no public exploit code.","fix":"Upgrade github.com/google/exposure-notifications-verification-server to 1.1.2 or later.","what":"CVE-2021-22565 is a medium-severity vulnerability in Google Exposure-notifications-verification-server, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22565 and fix it if it is affected.\n\nWhat it is: CVE-2021-22565 is a medium-severity vulnerability in Google Exposure-notifications-verification-server, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22565 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2\n- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2\n- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22565/ (Markdown: https://insights.sbomify.com/CVE-2021-22565/index.md)","id":"CVE-2021-22565","markdown":"https://insights.sbomify.com/CVE-2021-22565/index.md","name":"CVE-2021-22565","record":{"aliases":["GHSA-wx8q-rgfr-cf6v","GO-2022-0270"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Exposure Notification Server","requires_auth":"none","summary":"An attacker can prematurely expire verification codes, preventing patients from uploading exposure data to the server.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"exposure_notification_verification_server","vendor":"google"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient Granularity of Access Control in GAEN Notification Server","id":"CVE-2021-22565","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"business_logic","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Incorrect mapping of Executable bits in Fuchsia Kernel","id":"CVE-2021-22566"},"packages":[{"ecosystem":"Go","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"github.com/google/exposure-notifications-verification-server","purl":null,"source":"GHSA-wx8q-rgfr-cf6v"},{"ecosystem":"Go","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"github.com/google/exposure-notifications-verification-server","purl":"pkg:golang/github.com/google/exposure-notifications-verification-server","source":"GHSA-wx8q-rgfr-cf6v"},{"ecosystem":"Go","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"github.com/google/exposure-notifications-verification-server","purl":"pkg:golang/github.com/google/exposure-notifications-verification-server","source":"GO-2022-0270"}],"prev":{"headline":"Out of bounds Copy in Libjxl in large image groups","id":"CVE-2021-22564"},"products":["Google Exposure-notifications-verification-server"],"published":"2021-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Google LLC"]},"summary":"An attacker can prematurely expire verification codes, preventing patients from uploading exposure data to the server.","url":"https://insights.sbomify.com/CVE-2021-22565/"}