# CVE-2021-22565: Insufficient Granularity of Access Control in GAEN Notification Server

> An attacker can prematurely expire verification codes, preventing patients from uploading exposure data to the server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wx8q-rgfr-cf6v, GO-2022-0270

## What is CVE-2021-22565?

CVE-2021-22565 is a medium-severity vulnerability in Google Exposure-notifications-verification-server, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2021-22565?

3 open source packages ship an affected version, including github.com/google/exposure-notifications-verification-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/google/exposure-notifications-verification-server` | Go | All versions | 1.1.2 |
| `github.com/google/exposure-notifications-verification-server` | Go | All versions | 1.1.2 |
| `github.com/google/exposure-notifications-verification-server` | Go | All versions | 1.1.2 |

Products: Google Exposure Notification Verification Server.

## How do I fix CVE-2021-22565?

Upgrade github.com/google/exposure-notifications-verification-server to 1.1.2 or later.

## Is CVE-2021-22565 being exploited?

There is no known exploitation of CVE-2021-22565 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22565 and fix it if it is affected.

What it is: CVE-2021-22565 is a medium-severity vulnerability in Google Exposure-notifications-verification-server, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22565 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2
- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2
- github.com/google/exposure-notifications-verification-server (Go): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22565/ (Markdown: https://insights.sbomify.com/CVE-2021-22565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22565
- OSV: https://osv.dev/vulnerability/CVE-2021-22565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22565/
Summaries are generated and may contain mistakes; the official description above is the record.
