# CVE-2021-22573: Incorrect signature verification on Google-oauth-java-client

> Attackers can bypass authentication by providing unsigned ID tokens with custom payloads, allowing unauthorized access to applications using this library.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 May 2022
- **Updated:** 21 Apr 2025
- **Also known as:** CLSA-2026-1770682155, DEBIAN-CVE-2021-22573, GHSA-hw42-3568-wj87, OESA-2025-2429, OESA-2025-2430, OESA-2025-2431, OESA-2025-2432, OESA-2025-2433, OESA-2025-2434, SUSE-SU-2024:0806-1, UBUNTU-CVE-2021-22573

## What is CVE-2021-22573?

CVE-2021-22573 is a high-severity authentication bypass vulnerability in Google-oauth-java-client, published on 3 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The vulnerability is that IDToken verifier does not verify if token is properly signed. Signature verification makes sure that the token's payload comes from valid provider, not from someone else. An attacker can provide a compromised token with custom payload. The token will pass the validation on the client side. We recommend upgrading to version 1.33.3 or above

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2021-22573?

2 open source packages ship an affected version, including com.google.oauth-client:google-oauth-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.google.oauth-client:google-oauth-client` | Maven | From 1.16.0-rc | 1.33.3 |
| `com.google.oauth-client:google-oauth-client` | Maven | From 1.16.0-rc | 1.33.3 |
| `google-oauth-java-client` | openSUSE:Leap 15.5 | All versions | 1.22.0-150200.3.7.1 |

Products: Google Oauth Client Library for Java.

## How do I fix CVE-2021-22573?

Upgrade com.google.oauth-client:google-oauth-client to 1.33.3 or later.

## Is CVE-2021-22573 being exploited?

There is no known exploitation of CVE-2021-22573 in the wild and no public exploit code.

## Other vulnerabilities in Google-oauth-java-client

- [CVE-2020-7692](https://insights.sbomify.com/CVE-2020-7692/): Improper Authorization (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22573 and fix it if it is affected.

What it is: CVE-2021-22573 is a high-severity authentication bypass vulnerability in Google-oauth-java-client, published on 3 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22573 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.google.oauth-client:google-oauth-client (Maven): affected from 1.16.0-rc; fixed in 1.33.3
- com.google.oauth-client:google-oauth-client (Maven): affected from 1.16.0-rc; fixed in 1.33.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22573/ (Markdown: https://insights.sbomify.com/CVE-2021-22573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22573
- OSV: https://osv.dev/vulnerability/CVE-2021-22573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22573/
Summaries are generated and may contain mistakes; the official description above is the record.
