# CVE-2021-22696: OAuth 2 authorization service vulnerable to DDos attacks

> Apache CXF OAuth2 authorization service is vulnerable to denial of service via unvalidated request_uri parameters, allowing attackers to trigger excessive outbound requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2021
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-7q4h-pj78-j7vg

## What is CVE-2021-22696?

CVE-2021-22696 is a high-severity server-side request forgery vulnerability in Apache Cxf, published on 2 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CXF supports (via JwtRequestCodeFilter) passing OAuth 2 parameters via a JWT token as opposed to query parameters (see: The OAuth 2.0 Authorization Framework: JWT Secured Authorization Request (JAR)). Instead of sending a JWT token as a "request" parameter, the spec also supports specifying a URI from which to retrieve a JWT token from via the "request_uri" parameter. CXF was not validating the "request_uri" parameter (apart from ensuring it uses "https) and was making a REST request to the parameter in the request to retrieve a token. This means that CXF was vulnerable to DDos attacks on the authorization server, as specified in section 10.4.1 of the spec. This issue affects Apache CXF versions prior to 3.4.3; Apache CXF versions prior to 3.3.10.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-22696?

8 open source packages ship an affected version, including org.apache.cxf:apache-cxf and org.apache.cxf:cxf. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:apache-cxf` | Maven | All versions | 3.3.10 |
| `org.apache.cxf:apache-cxf` | Maven | All versions | 3.3.10 |
| `org.apache.cxf:apache-cxf` | Maven | From 3.4.0 | 3.4.3 |
| `org.apache.cxf:apache-cxf` | Maven | From 3.4.0 | 3.4.3 |
| `org.apache.cxf:cxf` | Maven | All versions | 3.3.10 |
| `org.apache.cxf:cxf` | Maven | All versions | 3.3.10 |
| `org.apache.cxf:cxf` | Maven | From 3.4.0 | 3.4.3 |
| `org.apache.cxf:cxf` | Maven | From 3.4.0 | 3.4.3 |

Products: Apache Cxf, Oracle Business Intelligence, Oracle Communications Diameter Intelligence Hub, Oracle Communications Element Manager, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager.

## How do I fix CVE-2021-22696?

Upgrade org.apache.cxf:apache-cxf to a fixed version for your release line: 3.3.10 or 3.4.3.

## Is CVE-2021-22696 being exploited?

There is no known exploitation of CVE-2021-22696 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22696 and fix it if it is affected.

What it is: CVE-2021-22696 is a high-severity server-side request forgery vulnerability in Apache Cxf, published on 2 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22696 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:apache-cxf (Maven): affected all versions; fixed in 3.3.10
- org.apache.cxf:apache-cxf (Maven): affected all versions; fixed in 3.3.10
- org.apache.cxf:apache-cxf (Maven): affected from 3.4.0; fixed in 3.4.3
- org.apache.cxf:apache-cxf (Maven): affected from 3.4.0; fixed in 3.4.3
- org.apache.cxf:cxf (Maven): affected all versions; fixed in 3.3.10
- org.apache.cxf:cxf (Maven): affected all versions; fixed in 3.3.10
- org.apache.cxf:cxf (Maven): affected from 3.4.0; fixed in 3.4.3
- org.apache.cxf:cxf (Maven): affected from 3.4.0; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22696/ (Markdown: https://insights.sbomify.com/CVE-2021-22696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22696
- OSV: https://osv.dev/vulnerability/CVE-2021-22696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22696/
Summaries are generated and may contain mistakes; the official description above is the record.
