# CVE-2021-22866: Security feature bypass in GitHub Enterprise Server

> UI misrepresentation in GitHub Enterprise Server allows attackers to obtain excessive user permissions during app authorization flows.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2p62-w27q-9g83

## What is CVE-2021-22866?

CVE-2021-22866 is a high-severity vulnerability in Github Enterprise Server, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed more permissions to be granted during a GitHub App's user-authorization web flow than was displayed to the user during approval. To exploit this vulnerability, an attacker would need to create a GitHub App on the instance and have a user authorize the application through the web authentication flow. All permissions being granted would properly be shown during the first authorization, but in certain circumstances, if the user revisits the authorization flow after the GitHub App has configured additional user-level permissions, those additional permissions may not be shown, leading to more permissions being granted than the user potentially intended. This vulnerability affected GitHub Enterprise Server 3.0.x prior to 3.0.7 and 2.22.x prior to 2.22.13. It was fixed in versions 3.0.7 and 2.22.13. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames), CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2021-22866?

It affects 1 product.


Products: Github Enterprise Server.

## How do I fix CVE-2021-22866?

No fix has been published for CVE-2021-22866 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-22866 being exploited?

There is no known exploitation of CVE-2021-22866 in the wild and no public exploit code.

## Other vulnerabilities in Github Enterprise Server

- [CVE-2024-4985](https://insights.sbomify.com/CVE-2024-4985/): Auth bypass in Enterprise Server (critical 10.0)
- [CVE-2022-23739](https://insights.sbomify.com/CVE-2022-23739/): Missing authorization in GitHub Enterprise Server (critical 9.8)
- [CVE-2022-46255](https://insights.sbomify.com/CVE-2022-46255/): Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE (critical 9.8)
- [CVE-2021-22869](https://insights.sbomify.com/CVE-2021-22869/): Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group (critical 9.8)
- [CVE-2024-9487](https://insights.sbomify.com/CVE-2024-9487/): Auth bypass in Enterprise Server (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22866 and fix it if it is affected.

What it is: CVE-2021-22866 is a high-severity vulnerability in Github Enterprise Server, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22866 in the wild and no public exploit code.

Affected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22866/ (Markdown: https://insights.sbomify.com/CVE-2021-22866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22866
- OSV: https://osv.dev/vulnerability/CVE-2021-22866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22866/
Summaries are generated and may contain mistakes; the official description above is the record.
