# CVE-2021-22880: Active Record subject to Regular Expression Denial-of-Service (ReDoS)

> Attackers can cause denial of service in Rails applications using PostgreSQL money columns via crafted input triggering ReDoS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-22880, GHSA-8hc4-xxm3-5ppp, SUSE-SU-2021:3267-1, SUSE-SU-2021:3634-1, UBUNTU-CVE-2021-22880, openSUSE-SU-2021:1468-1, openSUSE-SU-2021:3634-1

## What is CVE-2021-22880?

CVE-2021-22880 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-22880?

6 open source packages ship an affected version, including activerecord. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 5.0.0 | 5.2.4.5 |
| `activerecord` | RubyGems | From 5.0.0 | 5.2.4.5 |
| `activerecord` | RubyGems | From 6.0.0 | 6.0.3.5 |
| `activerecord` | RubyGems | From 6.0.0 | 6.0.3.5 |
| `activerecord` | RubyGems | From 6.1.0 | 6.1.2.1 |
| `activerecord` | RubyGems | From 6.1.0 | 6.1.2.1 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-5.3.3 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-5.3.3 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-5.3.3 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-5.3.3 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-6.6.1 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-6.6.1 |
| `rubygem-activerecord-5_1` | openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.4.3.1 |
| `rubygem-activerecord-5_1` | openSUSE:Leap 15.3 | All versions | 5.1.4-5.3.3 |

Products: Fedoraproject Fedora, Rubyonrails Rails.

## How do I fix CVE-2021-22880?

Upgrade activerecord to a fixed version for your release line: 5.2.4.5, 6.0.3.5 or 6.1.2.1.

## Is CVE-2021-22880 being exploited?

There is no known exploitation of CVE-2021-22880 in the wild and no public exploit code.

Public exploit code:

- https://github.com/halkichi0308/CVE-2021-22880 (github_poc): https://github.com/halkichi0308/CVE-2021-22880

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22880 and fix it if it is affected.

What it is: CVE-2021-22880 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22880 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 5.0.0; fixed in 5.2.4.5
- activerecord (RubyGems): affected from 5.0.0; fixed in 5.2.4.5
- activerecord (RubyGems): affected from 6.0.0; fixed in 6.0.3.5
- activerecord (RubyGems): affected from 6.0.0; fixed in 6.0.3.5
- activerecord (RubyGems): affected from 6.1.0; fixed in 6.1.2.1
- activerecord (RubyGems): affected from 6.1.0; fixed in 6.1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22880/ (Markdown: https://insights.sbomify.com/CVE-2021-22880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22880
- OSV: https://osv.dev/vulnerability/CVE-2021-22880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22880/
Summaries are generated and may contain mistakes; the official description above is the record.
