{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 9 products.","exploited":"There is no known exploitation of CVE-2021-22883 in the wild and no public exploit code.","fix":"Upgrade node to a fixed version for your release line: 10.24.0, 12.21.0, 14.16.0 or 15.10.0.","what":"CVE-2021-22883 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22883 and fix it if it is affected.\n\nWhat it is: CVE-2021-22883 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22883 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0\n- node-min (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22883/ (Markdown: https://insights.sbomify.com/CVE-2021-22883/index.md)","id":"CVE-2021-22883","markdown":"https://insights.sbomify.com/CVE-2021-22883/index.md","name":"CVE-2021-22883","record":{"aliases":["ALPINE-CVE-2021-22883","BIT-node-2021-22883","BIT-node-min-2021-22883","CLEANSTART-2026-LS05917","CLEANSTART-2026-ZM17844","DEBIAN-CVE-2021-22883","GHSA-mjgw-69fr-p4h2","UBUNTU-CVE-2021-22883"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can cause a denial of service in Node.js by exhausting file descriptors or memory through excessive unknown protocol connections.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"e-series_performance_analyzer","vendor":"netapp"},{"product":"node.js","vendor":"nodejs"},{"product":"graalvm","vendor":"oracle"},{"product":"jd_edwards_enterpriseone_tools","vendor":"oracle"},{"product":"mysql_cluster","vendor":"oracle"},{"product":"nosql_database","vendor":"oracle"},{"product":"peoplesoft_enterprise_peopletools","vendor":"oracle"},{"product":"sinec_infrastructure_network_services","vendor":"siemens"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-772","name":"Missing Release of Resource after Effective Lifetime"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Node","id":"CVE-2021-22883","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","netapp:e-series_performance_analyzer","nodejs:node.js","oracle:graalvm","oracle:jd_edwards_enterpriseone_tools","oracle:mysql_cluster","oracle:peoplesoft_enterprise_peopletools","siemens:sinec_infrastructure_network_services"],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":10,"next":{"headline":"Node.js bad","id":"CVE-2021-22884"},"packages":[{"ecosystem":"Bitnami","fixed":["10.24.0","12.21.0","14.16.0","15.10.0"],"introduced":["10.0.0","12.0.0","14.0.0","15.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2021-22883"},{"ecosystem":"Bitnami","fixed":["10.24.0","12.21.0","14.16.0","15.10.0"],"introduced":["10.0.0","12.0.0","14.0.0","15.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2021-22883"}],"prev":{"headline":"Denial of service in UniFi Protect","id":"CVE-2021-22882"},"products":["Node"],"published":"2021-03-03","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Attackers can cause a denial of service in Node.js by exhausting file descriptors or memory through excessive unknown protocol connections.","url":"https://insights.sbomify.com/CVE-2021-22883/"}