# CVE-2021-22883: Denial of service in Node

> Attackers can cause a denial of service in Node.js by exhausting file descriptors or memory through excessive unknown protocol connections.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-22883, BIT-node-2021-22883, BIT-node-min-2021-22883, CLEANSTART-2026-LS05917, CLEANSTART-2026-ZM17844, DEBIAN-CVE-2021-22883, GHSA-mjgw-69fr-p4h2, UBUNTU-CVE-2021-22883

## What is CVE-2021-22883?

CVE-2021-22883 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-22883?

2 open source packages ship an affected version, including node and node-min. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 10.0.0 | 10.24.0, 12.21.0, 14.16.0, 15.10.0 |
| `node-min` | Bitnami | From 10.0.0 | 10.24.0, 12.21.0, 14.16.0, 15.10.0 |

Products: Fedoraproject Fedora, Netapp E-Series Performance Analyzer, Nodejs Node.js, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Mysql Cluster, Oracle Nosql Database, Oracle Peoplesoft Enterprise Peopletools, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22883?

Upgrade node to a fixed version for your release line: 10.24.0, 12.21.0, 14.16.0 or 15.10.0.

## Is CVE-2021-22883 being exploited?

There is no known exploitation of CVE-2021-22883 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22883 and fix it if it is affected.

What it is: CVE-2021-22883 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22883 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0
- node-min (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22883/ (Markdown: https://insights.sbomify.com/CVE-2021-22883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22883
- OSV: https://osv.dev/vulnerability/CVE-2021-22883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22883/
Summaries are generated and may contain mistakes; the official description above is the record.
