# CVE-2021-22884: Node.js bad

> Attackers can bypass DNS rebinding protections in Node.js by exploiting the localhost6 whitelist entry, allowing access to local services.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-22884, BIT-node-2021-22884, BIT-node-min-2021-22884, CLEANSTART-2026-DP91673, CLEANSTART-2026-MS57961, DEBIAN-CVE-2021-22884, GHSA-2w6h-7cgj-qw4q, SUSE-SU-2021:0686-1, UBUNTU-CVE-2021-22884, openSUSE-SU-2021:0389-1

## What is CVE-2021-22884?

CVE-2021-22884 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to DNS rebinding attacks as the whitelist includes “localhost6”. When “localhost6” is not present in /etc/hosts, it is just an ordinary domain that is resolved via DNS, i.e., over network. If the attacker controls the victim's DNS server or can spoof its responses, the DNS rebinding protection can be bypassed by using the “localhost6” domain. As long as the attacker uses the “localhost6” domain, they can still apply the attack described in CVE-2018-7160.

Weakness: CWE-350 (Reliance on Reverse DNS Resolution for a Security-Critical Action)

## Which versions are affected by CVE-2021-22884?

2 open source packages ship an affected version, including node and node-min. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 10.0.0 | 10.24.0, 12.21.0, 14.16.0, 15.10.0 |
| `node-min` | Bitnami | From 10.0.0 | 10.24.0, 12.21.0, 14.16.0, 15.10.0 |
| `nodejs8` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 8.17.0-10.9.2 |
| `nodejs8` | openSUSE:Leap 15.2 | All versions | 8.17.0-lp152.3.11.1 |

Products: Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp E-Series Performance Analyzer, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Nodejs Node.js, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Mysql Cluster, Oracle Nosql Database, Oracle Peoplesoft Enterprise Peopletools, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22884?

Upgrade node to a fixed version for your release line: 10.24.0, 12.21.0, 14.16.0 or 15.10.0.

## Is CVE-2021-22884 being exploited?

There is no known exploitation of CVE-2021-22884 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22884 and fix it if it is affected.

What it is: CVE-2021-22884 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22884 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0
- node-min (Bitnami): affected from 10.0.0; fixed in 10.24.0, 12.21.0, 14.16.0, 15.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22884/ (Markdown: https://insights.sbomify.com/CVE-2021-22884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22884
- OSV: https://osv.dev/vulnerability/CVE-2021-22884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22884/
Summaries are generated and may contain mistakes; the official description above is the record.
