CVE-2021-22885 Action Pack contains Information Disclosure / Unintended Method Execution vulnerability
Attackers can trigger information disclosure or unintended method execution in Ruby on Rails Action Pack via untrusted input in redirect helpers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22885?
CVE-2021-22885 is a high-severity vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the `redirect_to` or `polymorphic_url`helper with untrusted user input.
Weakness: CWE-209
Which versions are affected by CVE-2021-22885?
8 open source packages ship an affected version, including actionpack. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 2.0.0 | 5.2.4.6 |
actionpack RubyGems | From 2.0.0 | 5.2.4.6 |
actionpack RubyGems | From 5.2.5 | 5.2.6 |
actionpack RubyGems | From 5.2.5 | 5.2.6 |
actionpack RubyGems | From 6.0.0 | 6.0.3.7 |
actionpack RubyGems | From 6.0.0 | 6.0.3.7 |
2 more packages
actionpack RubyGems | From 6.1.0 | 6.1.3.2 |
actionpack RubyGems | From 6.1.0 | 6.1.3.2 |
Linux distribution packages (9)
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.9.1 |
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.9.1 |
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-3.9.1 |
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-3.9.1 |
rubygem-actionpack-4_2 SUSE:OpenStack Cloud 7 | All versions | 4.2.9-7.12.1 |
rubygem-actionpack-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.12.1 |
rubygem-actionpack-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.12.1 |
rubygem-actionpack-5_1 openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.5.6.1 |
rubygem-actionpack-5_1 openSUSE:Leap 15.3 | All versions | 5.1.4-3.9.1 |
Products include Debian Debian Linux, Rubyonrails Actionpack Page-Caching, Rubyonrails Rails.
How do I fix CVE-2021-22885?
Upgrade actionpack to a fixed version for your release line: 5.2.4.6, 5.2.6, 6.0.3.7 or 6.1.3.2.
Is CVE-2021-22885 being exploited?
There is no known exploitation of CVE-2021-22885 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2021-22885, GHSA-hjg4-8q5f-x6fm, OESA-2021-1236, SUSE-SU-2021:1650-1, SUSE-SU-2021:1759-1, UBUNTU-CVE-2021-22885 and 2 more.