# CVE-2021-22885: Action Pack contains Information Disclosure / Unintended Method Execution vulnerability

> Attackers can trigger information disclosure or unintended method execution in Ruby on Rails Action Pack via untrusted input in redirect helpers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-22885, GHSA-hjg4-8q5f-x6fm, OESA-2021-1236, SUSE-SU-2021:1650-1, SUSE-SU-2021:1759-1, UBUNTU-CVE-2021-22885, openSUSE-SU-2021:0797-1, openSUSE-SU-2021:1759-1

## What is CVE-2021-22885?

CVE-2021-22885 is a high-severity vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the `redirect_to` or `polymorphic_url`helper with untrusted user input.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2021-22885?

8 open source packages ship an affected version, including actionpack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.0.0 | 5.2.4.6 |
| `actionpack` | RubyGems | From 2.0.0 | 5.2.4.6 |
| `actionpack` | RubyGems | From 5.2.5 | 5.2.6 |
| `actionpack` | RubyGems | From 5.2.5 | 5.2.6 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.7 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.7 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.3.2 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.3.2 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.9.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.9.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-3.9.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-3.9.1 |
| `rubygem-actionpack-4_2` | SUSE:OpenStack Cloud 7 | All versions | 4.2.9-7.12.1 |
| `rubygem-actionpack-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.12.1 |
| `rubygem-actionpack-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.12.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.5.6.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.3 | All versions | 5.1.4-3.9.1 |

Products: Debian Debian Linux, Rubyonrails Actionpack Page-Caching, Rubyonrails Rails.

## How do I fix CVE-2021-22885?

Upgrade actionpack to a fixed version for your release line: 5.2.4.6, 5.2.6, 6.0.3.7 or 6.1.3.2.

## Is CVE-2021-22885 being exploited?

There is no known exploitation of CVE-2021-22885 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22885 and fix it if it is affected.

What it is: CVE-2021-22885 is a high-severity vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22885 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.0.0; fixed in 5.2.4.6
- actionpack (RubyGems): affected from 2.0.0; fixed in 5.2.4.6
- actionpack (RubyGems): affected from 5.2.5; fixed in 5.2.6
- actionpack (RubyGems): affected from 5.2.5; fixed in 5.2.6
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.7
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.7
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.3.2
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22885/ (Markdown: https://insights.sbomify.com/CVE-2021-22885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22885
- OSV: https://osv.dev/vulnerability/CVE-2021-22885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22885/
Summaries are generated and may contain mistakes; the official description above is the record.
