# CVE-2021-22904: Possible DoS Vulnerability in Action Controller Token Authentication

> Attackers can cause denial of service in Ruby on Rails applications using token authentication due to a vulnerable regular expression.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-22904, GHSA-7wjx-3g7j-8584, OESA-2021-1248, UBUNTU-CVE-2021-22904

## What is CVE-2021-22904?

CVE-2021-22904 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-22904?

8 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 4.0.0 | 5.2.4.6 |
| `actionpack` | RubyGems | From 4.0.0 | 5.2.4.6 |
| `actionpack` | RubyGems | From 5.2.5 | 5.2.6 |
| `actionpack` | RubyGems | From 5.2.5 | 5.2.6 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.7 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.7 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.3.2 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.3.2 |

Products: Rubyonrails Rails.

## How do I fix CVE-2021-22904?

Upgrade actionpack to a fixed version for your release line: 5.2.4.6, 5.2.6, 6.0.3.7 or 6.1.3.2.

## Is CVE-2021-22904 being exploited?

There is no known exploitation of CVE-2021-22904 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22904 and fix it if it is affected.

What it is: CVE-2021-22904 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22904 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 4.0.0; fixed in 5.2.4.6
- actionpack (RubyGems): affected from 4.0.0; fixed in 5.2.4.6
- actionpack (RubyGems): affected from 5.2.5; fixed in 5.2.6
- actionpack (RubyGems): affected from 5.2.5; fixed in 5.2.6
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.7
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.7
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.3.2
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22904/ (Markdown: https://insights.sbomify.com/CVE-2021-22904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22904
- OSV: https://osv.dev/vulnerability/CVE-2021-22904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22904/
Summaries are generated and may contain mistakes; the official description above is the record.
