# CVE-2021-22918: Out-of-Bounds Read in Node.js

> An out-of-bounds read in Node.js allows attackers to disclose sensitive information or cause crashes via DNS resolution functions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-22918, ALSA-2021:3075, AZL-41581, BIT-node-2021-22918, BIT-node-min-2021-22918, DEBIAN-CVE-2021-22918, DSA-4936-1, GHSA-x3cj-3539-rcpx, MGASA-2021-0360, OESA-2021-1291, OESA-2022-1933, RHSA-2021:3075, RLSA-2021:3075, UBUNTU-CVE-2021-22918, USN-5007-1, openSUSE-SU-2024:11007-1

## What is CVE-2021-22918?

CVE-2021-22918 is a medium-severity vulnerability in Nodejs Node.js, published on 12 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-22918?

2 open source packages ship an affected version, including node and node-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |
| `node-min` | Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |
| `libuv` | AlmaLinux:8 | All versions | 1:1.41.1-1.el8_4 |
| `libuv-devel` | AlmaLinux:8 | All versions | 1:1.41.1-1.el8_4 |
| `libuv` | Red Hat:enterprise_linux:8::appstream | All versions | 1:1.41.1-1.el8_4 |
| `libuv-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 1:1.41.1-1.el8_4 |
| `libuv-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 1:1.41.1-1.el8_4 |
| `libuv-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 1:1.41.1-1.el8_4 |
| `libuv-debugsource` | Red Hat:enterprise_linux:8::crb | All versions | 1:1.41.1-1.el8_4 |
| `libuv-devel` | Red Hat:enterprise_linux:8::crb | All versions | 1:1.41.1-1.el8_4 |
| `libuv` | Rocky Linux:8 | All versions | 1:1.41.1-1.el8_4 |
| `libuv` | openSUSE:Tumbleweed | All versions | 1.42.0-1.2 |

Products: Nodejs Node.js, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22918?

Upgrade node to a fixed version for your release line: 12.22.2, 14.17.2 or 16.4.1.

## Is CVE-2021-22918 being exploited?

There is no known exploitation of CVE-2021-22918 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22918 and fix it if it is affected.

What it is: CVE-2021-22918 is a medium-severity vulnerability in Nodejs Node.js, published on 12 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22918 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.22.2, 14.17.2, 16.4.1
- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.2, 14.17.2, 16.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22918/ (Markdown: https://insights.sbomify.com/CVE-2021-22918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22918
- OSV: https://osv.dev/vulnerability/CVE-2021-22918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22918/
Summaries are generated and may contain mistakes; the official description above is the record.
