CVE-2021-22921 Incorrect Permission Assignment for Critical Resource in Node
Local attackers can escalate privileges on Windows via PATH or DLL hijacking due to improper installation directory permissions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-22921?
CVE-2021-22921 is a high-severity vulnerability in Nodejs Node.js, published on 12 Jul 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.
Weakness: CWE-732
Which versions are affected by CVE-2021-22921?
2 open source packages ship an affected version, including node and node-min. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |
node-min Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |
Products include Nodejs Node.js, Siemens Sinec Infrastructure Network Services.
How do I fix CVE-2021-22921?
Upgrade node to a fixed version for your release line: 12.22.2, 14.17.2 or 16.4.1.
Is CVE-2021-22921 being exploited?
There is no known exploitation of CVE-2021-22921 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Node.js
Sources
Also known as BIT-node-2021-22921, BIT-node-min-2021-22921, GHSA-g3w9-g82h-cmp4.