# CVE-2021-22921: Incorrect Permission Assignment for Critical Resource in Node

> Local attackers can escalate privileges on Windows via PATH or DLL hijacking due to improper installation directory permissions.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2021
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-node-2021-22921, BIT-node-min-2021-22921, GHSA-g3w9-g82h-cmp4

## What is CVE-2021-22921?

CVE-2021-22921 is a high-severity vulnerability in Nodejs Node.js, published on 12 Jul 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2021-22921?

2 open source packages ship an affected version, including node and node-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |
| `node-min` | Bitnami | From 12.0.0 | 12.22.2, 14.17.2, 16.4.1 |

Products: Nodejs Node.js, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22921?

Upgrade node to a fixed version for your release line: 12.22.2, 14.17.2 or 16.4.1.

## Is CVE-2021-22921 being exploited?

There is no known exploitation of CVE-2021-22921 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22921 and fix it if it is affected.

What it is: CVE-2021-22921 is a high-severity vulnerability in Nodejs Node.js, published on 12 Jul 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22921 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.22.2, 14.17.2, 16.4.1
- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.2, 14.17.2, 16.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22921/ (Markdown: https://insights.sbomify.com/CVE-2021-22921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22921
- OSV: https://osv.dev/vulnerability/CVE-2021-22921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22921/
Summaries are generated and may contain mistakes; the official description above is the record.
