# CVE-2021-22930: Use After Free in node.js

> An attacker can exploit a use-after-free vulnerability in Node.js to cause memory corruption, potentially leading to arbitrary code execution or privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-22930, AZL-6742, BIT-node-2021-22930, BIT-node-min-2021-22930, CLEANSTART-2026-JX16317, CLEANSTART-2026-TJ44267, DEBIAN-CVE-2021-22930, GHSA-gqhp-5j32-xwmm, MGASA-2021-0394, OESA-2021-1409, SUSE-SU-2021:2790-1, SUSE-SU-2021:3294-1, UBUNTU-CVE-2021-22930, openSUSE-SU-2021:1343-1, openSUSE-SU-2021:3294-1

## What is CVE-2021-22930?

CVE-2021-22930 is a critical use after free vulnerability in Debian Debian Linux, published on 7 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-22930?

2 open source packages ship an affected version, including node and node-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.22.4, 14.17.4, 16.6.0 |
| `node-min` | Bitnami | From 12.0.0 | 12.22.4, 14.17.4, 16.6.0 |
| `nodejs8` | SUSE:Enterprise Storage 6 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 8.17.0-10.15.11 |
| `nodejs8` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Manager Proxy 4.0 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Manager Retail Branch Server 4.0 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | SUSE:Manager Server 4.0 | All versions | 8.17.0-3.50.1 |
| `nodejs8` | openSUSE:Leap 15.2 | All versions | 8.17.0-lp152.3.17.1 |
| `nodejs8` | openSUSE:Leap 15.3 | All versions | 8.17.0-10.15.11 |

Products: Debian Debian Linux, Netapp Nextgen Api, Nodejs Node.js, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22930?

Upgrade node to a fixed version for your release line: 12.22.4, 14.17.4 or 16.6.0.

## Is CVE-2021-22930 being exploited?

There is no known exploitation of CVE-2021-22930 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22930 and fix it if it is affected.

What it is: CVE-2021-22930 is a critical use after free vulnerability in Debian Debian Linux, published on 7 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22930 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.22.4, 14.17.4, 16.6.0
- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.4, 14.17.4, 16.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22930/ (Markdown: https://insights.sbomify.com/CVE-2021-22930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22930
- OSV: https://osv.dev/vulnerability/CVE-2021-22930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22930/
Summaries are generated and may contain mistakes; the official description above is the record.
