# CVE-2021-22931: Code injection in Node

> Attackers can execute code or hijack domains via DNS response injection in Node.js due to missing hostname validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-22931, AZL-32282, AZL-6743, BIT-node-2021-22931, BIT-node-min-2021-22931, CLEANSTART-2026-EB92490, CLEANSTART-2026-KA98679, GHSA-7r9p-c88x-w357

## What is CVE-2021-22931?

CVE-2021-22931 is a critical code injection vulnerability in Netapp Active Iq Unified Manager, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

Weakness: CWE-20 (Improper Input Validation), CWE-170 (Improper Null Termination)

## Which versions are affected by CVE-2021-22931?

2 open source packages ship an affected version, including node and node-min. It affects 10 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2 |
| `node-min` | Bitnami | From 12.0.0 | 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2 |

Products: Netapp Active Iq Unified Manager, Netapp Nextgen Api, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Nodejs Node.js, Oracle Graalvm, Oracle Mysql Cluster, Oracle Peoplesoft Enterprise Peopletools, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22931?

Upgrade node to a fixed version for your release line: 12.12.1, 12.22.5, 14.14.1 or 14.17.5.

## Is CVE-2021-22931 being exploited?

There is no known exploitation of CVE-2021-22931 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)
- [CVE-2018-2941](https://insights.sbomify.com/CVE-2018-2941/): Code injection in Java (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22931 and fix it if it is affected.

What it is: CVE-2021-22931 is a critical code injection vulnerability in Netapp Active Iq Unified Manager, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22931 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2
- node-min (Bitnami): affected from 12.0.0; fixed in 12.12.1, 12.22.5, 14.14.1, 14.17.5, 16.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22931/ (Markdown: https://insights.sbomify.com/CVE-2021-22931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22931
- OSV: https://osv.dev/vulnerability/CVE-2021-22931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22931/
Summaries are generated and may contain mistakes; the official description above is the record.
