CVE-2021-22940 Use after free in Node
Attackers can exploit a use-after-free flaw in Node.js to corrupt memory and potentially execute arbitrary code or escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22940?
CVE-2021-22940 is a high-severity use after free vulnerability in Debian Debian Linux, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
Weakness: CWE-416
Which versions are affected by CVE-2021-22940?
2 open source packages ship an affected version, including node and node-min. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 12.0.0 | 12.22.5, 14.17.5, 16.6.2 |
node-min Bitnami | From 12.0.0 | 12.22.5, 14.17.5, 16.6.2 |
Products include Debian Debian Linux, Netapp Nextgen Api, Nodejs Node.js, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools and 1 more.
How do I fix CVE-2021-22940?
Upgrade node to a fixed version for your release line: 12.22.5, 14.17.5 or 16.6.2.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2021-22940 being exploited?
There is no known exploitation of CVE-2021-22940 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-6745, BIT-node-2021-22940, BIT-node-min-2021-22940, DEBIAN-CVE-2021-22940, GHSA-6hhj-4h22-mrmm.