{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 7 products.","exploited":"There is no known exploitation of CVE-2021-22940 in the wild and no public exploit code.","fix":"Upgrade node to a fixed version for your release line: 12.22.5, 14.17.5 or 16.6.2.","what":"CVE-2021-22940 is a high-severity use after free vulnerability in Debian Debian Linux, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22940 and fix it if it is affected.\n\nWhat it is: CVE-2021-22940 is a high-severity use after free vulnerability in Debian Debian Linux, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22940 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 12.0.0; fixed in 12.22.5, 14.17.5, 16.6.2\n- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.5, 14.17.5, 16.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22940/ (Markdown: https://insights.sbomify.com/CVE-2021-22940/index.md)","id":"CVE-2021-22940","markdown":"https://insights.sbomify.com/CVE-2021-22940/index.md","name":"CVE-2021-22940","record":{"aliases":["AZL-6745","BIT-node-2021-22940","BIT-node-min-2021-22940","DEBIAN-CVE-2021-22940","GHSA-6hhj-4h22-mrmm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can exploit a use-after-free flaw in Node.js to corrupt memory and potentially execute arbitrary code or escalate privileges.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"nextgen_api","vendor":"netapp"},{"product":"node.js","vendor":"nodejs"},{"product":"graalvm","vendor":"oracle"},{"product":"jd_edwards_enterpriseone_tools","vendor":"oracle"},{"product":"peoplesoft_enterprise_peopletools","vendor":"oracle"},{"product":"sinec_infrastructure_network_services","vendor":"siemens"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in Node","id":"CVE-2021-22940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","nodejs:node.js","oracle:graalvm","oracle:jd_edwards_enterpriseone_tools","oracle:peoplesoft_enterprise_peopletools","siemens:sinec_infrastructure_network_services"],"type":"use_after_free","year":"2021"},"n_packages":2,"n_references":9,"next":{"headline":"Citrix ShareFile Improper Access Control","id":"CVE-2021-22941"},"packages":[{"ecosystem":"Bitnami","fixed":["12.22.5","14.17.5","16.6.2"],"introduced":["12.0.0","14.0.0","16.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2021-22940"},{"ecosystem":"Bitnami","fixed":["12.22.5","14.17.5","16.6.2"],"introduced":["12.0.0","14.0.0","16.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2021-22940"}],"prev":{"headline":"Security feature bypass in Node","id":"CVE-2021-22939"},"products":["Node"],"published":"2021-08-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Attackers can exploit a use-after-free flaw in Node.js to corrupt memory and potentially execute arbitrary code or escalate privileges.","url":"https://insights.sbomify.com/CVE-2021-22940/"}