# CVE-2021-22940: Use after free in Node

> Attackers can exploit a use-after-free flaw in Node.js to corrupt memory and potentially execute arbitrary code or escalate privileges.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2021
- **Updated:** 30 Apr 2025
- **Also known as:** AZL-6745, BIT-node-2021-22940, BIT-node-min-2021-22940, DEBIAN-CVE-2021-22940, GHSA-6hhj-4h22-mrmm

## What is CVE-2021-22940?

CVE-2021-22940 is a high-severity use after free vulnerability in Debian Debian Linux, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-22940?

2 open source packages ship an affected version, including node and node-min. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.22.5, 14.17.5, 16.6.2 |
| `node-min` | Bitnami | From 12.0.0 | 12.22.5, 14.17.5, 16.6.2 |

Products: Debian Debian Linux, Netapp Nextgen Api, Nodejs Node.js, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-22940?

Upgrade node to a fixed version for your release line: 12.22.5, 14.17.5 or 16.6.2.

## Is CVE-2021-22940 being exploited?

There is no known exploitation of CVE-2021-22940 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22940 and fix it if it is affected.

What it is: CVE-2021-22940 is a high-severity use after free vulnerability in Debian Debian Linux, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22940 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.22.5, 14.17.5, 16.6.2
- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.5, 14.17.5, 16.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22940/ (Markdown: https://insights.sbomify.com/CVE-2021-22940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22940
- OSV: https://osv.dev/vulnerability/CVE-2021-22940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22940/
Summaries are generated and may contain mistakes; the official description above is the record.
